Przeglądasz artykuły oznaczone " php"
Wrz
14
2015

WordPress znacząco podnosi wymagania systemowe: serwer powinien mieć PHP 5.6

Każdy programista pracujący z WordPressem obudzony w środku nocy, na pytanie „Jaka jest minimalna wersja PHP konieczna do uruchomienia WP” bez wahania odpowie, że 5.2. To od teraz staje się nieco nieprawdziwe. Twórcy WordPressa właśnie zaktualizowali stronę „Requirements” – od teraz dowiemy się z niej, że należy posiadać PHP w wersji 5.6 lub nowszej. To bardzo dobra wiadomość dla twórców motywów i wtyczek: ostatnia wersja z linii 5.2.x wydana była 4 lata temu, a wszystkie […]

Cze
24
2012

Pobieranie wpisów bez używania query_posts

Tym razem wpis wyjątkowy, bo nie będący naszego autorstwa. To tłumaczenie tekstu, jaki opublikował John James Jacoby z Automattic, który pierwotnie ukazał się na blogu developerów z tej firmy. Problem w nim poruszony uznałem za tak ważny (i zarazem uważam podobnie jak autor, że query_posts() jest nadużywane w niewłaściwy sposób), że postanowiłem zapytać Jamesa czy możemy tutaj, na dev.wpzlecenia umieścić jego tłumaczenie. „Spread the words” – brzmiała odpowiedź. Nie przedłużając – oto tekst. Tutaj na […]

Mar
13
2012

Tworzymy wtyczkę poprawiającą funkcjonowanie Kokpitu na ekranach dotykowych

Kokpicie, daj się dotknąć Gdy ktoś dodaje zlecenie na WPzlecenia.pl, zlecenie zapisywane jest jak szkic wordpressowego wpisu, a ja dostaję o tym informację na maila z linkiem do tej części Kokpitu, w której mogę szybko zmienić status z szkic, na opublikowny. Powyższy widok jest chyba wszystkim wordpressowcom znany: po najechaniu myszką na listę wpisów przy każdym z nich pojawia się zestaw kilku linków. Gdy klikniemy w jeden z nich – Szybka edycja – widzimy to […]

Lis
1
2011

Sprawdź, czy luka w TimThumb nie zagraża twojemu WordPressowi

Milion ofiar małej dziury – tak można podsumować co ostatnio stało się w sieci. Bardzo popularny skrypt PHP do przeskalowywania zdjęć, często implementowany w rozwiązaniach opartych na WordPressie zaliczył sporą wpadkę bezpieczeństwa. Właśnie przeczytałem, że do dnia dzisiejszego ponad milion stron została przez to zaatakowana. Nawet mi samemu zdarzyło się realizować zlecenie na usunięcie pogromu jaki uczynili włamywacze. Myślę, że to jest dobry moment, aby przenieść tutaj kolejny mój wpis zamieszczony gdzie indziej. Tak oto […]

Paź
19
2011

Przeciętny bloger używa WordPressa 3.0, PHP 5.2 oraz MySQL 5.0

Wygląda na to, że niczego nie da się już ukryć. Gdy tylko wchodzisz do kokpitu swojego WordPressa, ten sprawdza czy na serwerze WordPress.org jest dostępna do pobrania nowsza wersja tego oprogramowania. Podczas tej czynności twoja instalacja WP wysyła do serwera nieco informacji. Wśród nich są dane dotyczące wersji silnika WordPressa, interpretera języka PHP oraz bazy danych MySQL. Jako, że WordPress jest najpopularniejszym na świecie systemem CMS (ostatnią wersję pobrano już ponad 10 milionów razy), wordpress.org […]

Uwaga, leci reklama:



Gdzie nas czytać?

Autorzy »
Komentujący »
#wpzlecenia »